media-sound/alsa-utils: arm64 stable (bug #720810)
[gentoo.git] / media-sound / vsound / vsound-0.6-r1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit autotools
7
8 DESCRIPTION="A virtual audio loopback cable"
9 HOMEPAGE="http://www.vsound.org/"
10 SRC_URI="http://www.vsound.org/${P}.tar.gz"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="amd64 ~ppc sparc x86"
15 IUSE=""
16
17 RDEPEND="media-sound/sox:="
18 DEPEND="${RDEPEND}"
19
20 PATCHES=(
21         "${FILESDIR}"/${P}-stdout.patch
22         "${FILESDIR}"/${P}-fix-build-system.patch
23 )
24
25 src_prepare() {
26         default
27         mv configure.{in,ac} || die
28         eautoreconf
29 }
30
31 src_install() {
32         default
33         find "${D}" -name '*.la' -delete || die
34 }
35
36 pkg_postinst() {
37         elog
38         elog "To use this program to, for instance, record audio from realplayer:"
39         elog "vsound realplay realmediafile.rm"
40         elog
41         elog "Or, to listen to realmediafile.rm at the same time:"
42         elog "vsound -d realplay realmediafile.rm"
43         elog
44         elog "See ${HOMEPAGE} or /usr/share/doc/${PF}/README.bz2 for more info"
45         elog
46 }