app-editors/kakoune: drop old 0_pre20160620
[gentoo.git] / media-sound / volwheel / volwheel-0.2.8-r1.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 inherit eutils gnome2-utils
6
7 DESCRIPTION="A volume control trayicon with mouse wheel support"
8 HOMEPAGE="http://oliwer.net/b/volwheel.html"
9 SRC_URI="https://olwtools.googlecode.com/files/${P}.tar.gz"
10
11 LICENSE="GPL-3"
12 SLOT="0"
13 KEYWORDS="amd64 ~mips x86"
14 IUSE="alsa"
15
16 DEPEND="dev-lang/perl"
17 RDEPEND="${DEPEND}
18         dev-perl/Gtk2
19         alsa? ( media-sound/alsa-utils )"
20
21 src_prepare() {
22         epatch "${FILESDIR}"/${P}-perl516.patch
23         sed -i -e '/^Encoding/d' ${PN}.desktop || die
24 }
25
26 src_install() {
27         ./install.pl prefix=/usr destdir="${D}" || die
28         dodoc ChangeLog README TODO
29 }
30
31 pkg_preinst() { gnome2_icon_savelist; }
32 pkg_postinst() { gnome2_icon_cache_update; }
33 pkg_postrm() { gnome2_icon_cache_update; }