media-sound/qtractor: removed obsolete 0.9.12
[gentoo.git] / media-sound / vkeybd / vkeybd-0.1.18d.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit toolchain-funcs
7
8 DESCRIPTION="A virtual MIDI keyboard for X"
9 HOMEPAGE="http://www.alsa-project.org/~iwai/alsa.html"
10 SRC_URI="http://ftp.suse.com/pub/people/tiwai/${PN}/${P}.tar.bz2"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="amd64 ~sparc x86"
15 IUSE="alsa lash oss"
16
17 RDEPEND="
18         >=dev-lang/tk-8.3:=
19         x11-libs/libX11
20         alsa? ( media-libs/alsa-lib:= )
21         lash? ( media-sound/lash:= )"
22 DEPEND="${RDEPEND}
23         x11-base/xorg-proto
24         virtual/pkgconfig"
25
26 S=${WORKDIR}/${PN}
27 PATCHES=(
28         "${FILESDIR}"/${PN}-0.1.18c-desktop_entry.patch
29         "${FILESDIR}"/${PN}-0.1.18c-fix-buildsystem.patch
30 )
31
32 src_configure() {
33         export TCL_VERSION="$(echo 'puts [info tclversion]' | tclsh)"
34
35         export USE_ALSA=$(usex alsa 1 0)
36         export USE_AWE=$(usex alsa $(usex oss 1 0) 1)
37         export USE_MIDI=$(usex alsa $(usex oss 1 0) 1)
38         export USE_LASH=$(usex lash 1 0)
39
40         tc-export CC PKG_CONFIG
41 }
42
43 pkg_postinst() {
44         elog "The system-wide keymap is locale-sensitive now. A file"
45         elog "vkeybdmap-\$LANG is searched in prior. For example, /etc/vkeybdmap-de"
46         elog "can be used for the german locale. See the localization guide:"
47         elog
48         elog "https://wiki.gentoo.org/wiki/Localization/Guide"
49 }