media-sound/alsa-utils: amd64 stable wrt bug #720810
[gentoo.git] / media-sound / vimpc / vimpc-9999.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit autotools git-r3
7
8 DESCRIPTION="An ncurses based mpd client with vi like key bindings"
9 HOMEPAGE="https://github.com/boysetsfrog/vimpc"
10 EGIT_REPO_URI="https://github.com/boysetsfrog/${PN}.git"
11
12 LICENSE="GPL-3"
13 SLOT="0"
14 IUSE="boost taglib"
15
16 RDEPEND="dev-libs/libpcre
17         media-libs/libmpdclient
18         boost? ( dev-libs/boost:= )
19         taglib? ( media-libs/taglib )"
20 DEPEND="${RDEPEND}"
21 BDEPEND="virtual/pkgconfig"
22
23 DOCS=( AUTHORS README.md doc/vimpcrc.example )
24
25 src_prepare() {
26         default
27         eautoreconf
28 }
29
30 src_configure() {
31         econf \
32                 $(use_enable boost) \
33                 $(use_enable taglib)
34 }
35
36 src_install() {
37         default
38
39         # vimpc will look for help.txt
40         docompress -x /usr/share/doc/${PF}/help.txt
41 }