media-sound/gsm: Fix prefixed installation by using ${ED}
[gentoo.git] / media-sound / upmpdcli / upmpdcli-1.4.0.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit systemd user
7
8 DESCRIPTION="UPnP Media Renderer front-end for MPD, the Music Player Daemon"
9 HOMEPAGE="https://www.lesbonscomptes.com/upmpdcli/index.html"
10 LICENSE="GPL-2"
11
12 SRC_URI="https://www.lesbonscomptes.com/upmpdcli/downloads/${P}.tar.gz"
13 SLOT="0"
14 KEYWORDS="amd64"
15 IUSE="thirdparty"
16
17 DEPEND="
18         dev-libs/jsoncpp
19         media-libs/libmpdclient
20         net-libs/libmicrohttpd
21         >=net-libs/libupnpp-0.17.0
22 "
23 RDEPEND="
24         ${DEPEND}
25         thirdparty? ( dev-python/requests )
26 "
27
28 pkg_setup() {
29         enewuser "${PN}"
30         enewgroup "${PN}"
31 }
32
33 src_install() {
34         default
35         newinitd "${FILESDIR}/${PN}.initd" "${PN}"
36         newconfd "${FILESDIR}/${PN}.confd" "${PN}"
37         systemd_dounit systemd/upmpdcli.service
38 }
39
40 pkg_postinst() {
41         einfo
42         einfo "This package no longer assumes that upmpdcli is driving an"
43         einfo "mpdinstance on the same host (https://bugs.gentoo.org/670130)."
44         einfo "Probably it is though, so be sure your mpd is built with"
45         einfo "USE=curl."
46         einfo
47         einfo "Consider installing media-sound/sc2mpd.  If upmpdcli"
48         einfo "detects sc2mpd at run-time, capabilities are added"
49         einfo "including internet radio support.  See upstream docs"
50         einfo "for more information."
51 }