media-sound/strawberry: Removed old
[gentoo.git] / media-sound / toolame / toolame-02l-r4.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 inherit eutils flag-o-matic toolchain-funcs
6
7 DESCRIPTION="tooLAME - an optimized mpeg 1/2 layer 2 audio encoder"
8 HOMEPAGE="http://www.planckenergy.com"
9 SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
10
11 LICENSE="LGPL-2.1"
12 SLOT="0"
13 KEYWORDS="~alpha amd64 arm hppa ~ia64 ppc ppc64 sparc x86"
14 IUSE=""
15
16 PATCHES=(
17         "${FILESDIR}/${P}-gentoo.diff"
18         "${FILESDIR}/${P}-uint.patch"
19         "${FILESDIR}/${P}-uint32_t.patch"
20 )
21
22 src_prepare() {
23         # fix #571774 by restoring pre-GCC5 inline semantics
24         append-cflags -std=gnu89
25
26         append-lfs-flags
27         tc-export CC
28
29         default
30 }
31
32 src_install() {
33         dobin ${PN}
34         dodoc README HISTORY FUTURE html/* text/*
35 }