media-sound/toolame: ppc stable wrt bug #605154
[gentoo.git] / media-sound / toolame / toolame-02l-r4.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=6
6 inherit eutils flag-o-matic toolchain-funcs
7
8 DESCRIPTION="tooLAME - an optimized mpeg 1/2 layer 2 audio encoder"
9 HOMEPAGE="http://www.planckenergy.com"
10 SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
11
12 LICENSE="LGPL-2.1"
13 SLOT="0"
14 KEYWORDS="~alpha amd64 ~hppa ~ia64 ppc ~ppc64 ~sparc x86 ~amd64-fbsd ~x86-fbsd"
15 IUSE=""
16
17 PATCHES=(
18         "${FILESDIR}/${P}-gentoo.diff"
19         "${FILESDIR}/${P}-uint.patch"
20         "${FILESDIR}/${P}-uint32_t.patch"
21 )
22
23 src_prepare() {
24         # fix #571774 by restoring pre-GCC5 inline semantics
25         append-cflags -std=gnu89
26
27         append-lfs-flags
28         tc-export CC
29
30         default
31 }
32
33 src_install() {
34         dobin ${PN}
35         dodoc README HISTORY FUTURE html/* text/*
36 }