media-sound/qjackctl: x86 stable wrt bug #720424
[gentoo.git] / media-sound / tempest_for_eliza / tempest_for_eliza-1.0.5-r2.ebuild
1 # Copyright 1999-2018 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit toolchain-funcs
7
8 DESCRIPTION="Listen to music on the radio generated by images on your screen"
9 HOMEPAGE="http://www.erikyyy.de/tempest/"
10 SRC_URI="http://www.erikyyy.de/tempest/${P}.tar.gz"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="amd64 ~ppc x86"
15
16 RDEPEND="media-libs/libsdl"
17 DEPEND="${RDEPEND}"
18
19 src_configure() {
20         tc-export CXX
21         econf \
22                 --enable-debug \
23                 --enable-nowarnerror
24 }
25
26 src_compile() {
27         emake CXXFLAGS="${CXXFLAGS}" LDFLAGS="${LDFLAGS}"
28 }
29
30 src_install() {
31         default
32         rm songs/Makefile* || die
33         insinto /usr/share/${PN}
34         doins songs/*
35 }