Merge remote-tracking branch 'github/pr/608'.
[gentoo.git] / media-sound / tagtool / tagtool-0.12.3-r1.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=6
6
7 inherit autotools
8
9 DESCRIPTION="Audio Tag Tool Ogg/Mp3 Tagger"
10 HOMEPAGE="http://pwp.netcabo.pt/paol/tagtool"
11 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~amd64 ~ppc ~sparc ~x86"
16 IUSE="mp3 +vorbis"
17 REQUIRED_USE="|| ( mp3 vorbis )"
18
19 RDEPEND="x11-libs/gtk+:2
20         >=gnome-base/libglade-2.6
21         mp3? ( >=media-libs/id3lib-3.8.3-r6 )
22         vorbis? ( >=media-libs/libvorbis-1 )"
23 DEPEND="${RDEPEND}
24         virtual/pkgconfig"
25
26 PATCHES=(
27         "${FILESDIR}"/${P}-underlinking.patch
28 )
29
30 src_prepare() {
31         # QA fix for wrong boolean value
32         sed -i -e 's/Terminal=False/Terminal=false/' data/tagtool.desktop.in || die
33
34         default
35         eautoreconf
36 }
37
38 src_configure() {
39         econf \
40                 $(use_enable mp3) \
41                 $(use_enable vorbis)
42 }
43
44 src_install() {
45         emake \
46                 DESTDIR="${D}" \
47                 GNOME_SYSCONFDIR="${D}/etc" \
48                 sysdir="${D}/usr/share/applets/Multimedia" \
49                 install
50
51         dodoc ChangeLog NEWS README TODO THANKS
52 }