media-sound/spotify: remove the dep on threads for curl
[gentoo.git] / media-sound / soundkonverter / soundkonverter-3.0.1-r1.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit kde5
7
8 DESCRIPTION="Frontend to various audio converters"
9 HOMEPAGE="https://www.linux-apps.com/search?projectSearchText=soundKonverter
10         https://github.com/dfaust/soundkonverter"
11 SRC_URI="https://github.com/dfaust/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
12
13 LICENSE="GPL-2"
14 KEYWORDS="~amd64 ~x86"
15 IUSE=""
16
17 COMMON_DEPEND="
18         $(add_frameworks_dep kcompletion)
19         $(add_frameworks_dep kconfig)
20         $(add_frameworks_dep kconfigwidgets)
21         $(add_frameworks_dep kcoreaddons)
22         $(add_frameworks_dep kdelibs4support)
23         $(add_frameworks_dep ki18n)
24         $(add_frameworks_dep kio)
25         $(add_frameworks_dep knotifications)
26         $(add_frameworks_dep kservice)
27         $(add_frameworks_dep ktextwidgets)
28         $(add_frameworks_dep kwidgetsaddons)
29         $(add_frameworks_dep kxmlgui)
30         $(add_frameworks_dep solid)
31         $(add_kdeapps_dep libkcddb)
32         $(add_qt_dep qtgui)
33         $(add_qt_dep qtwidgets)
34         $(add_qt_dep qtxml)
35         media-libs/phonon[qt5(+)]
36         >=media-libs/taglib-1.10
37         media-sound/cdparanoia
38 "
39 DEPEND="${COMMON_DEPEND}
40         sys-devel/gettext
41 "
42 RDEPEND="${COMMON_DEPEND}
43         !media-sound/soundkonverter:4
44 "
45
46 PATCHES=( "${FILESDIR}/${PN}-3.0.0-deps.patch" )
47
48 S="${WORKDIR}"/${P}/src
49
50 pkg_postinst() {
51         kde5_pkg_postinst
52
53         elog "soundKonverter optionally supports many different audio formats."
54         elog "You will need to install the appropriate encoding packages for the"
55         elog "formats you require. For a full listing, consult the README file"
56         elog "in /usr/share/doc/${PF}"
57 }