media-sound/lollypop: python 3.{7,8} support
[gentoo.git] / media-sound / soundconverter / soundconverter-3.0.2-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 PYTHON_COMPAT=( python3_6 )
6
7 inherit gnome2 python-single-r1
8
9 DESCRIPTION="A simple audiofile converter application for the GNOME environment"
10 HOMEPAGE="https://soundconverter.org/"
11 MY_PV="${PV/_/-}"
12 SRC_URI="https://launchpad.net/${PN}/trunk/${MY_PV}/+download/${PN}-${MY_PV}.tar.xz"
13 S="${WORKDIR}/${PN}-${MY_PV}"
14
15 LICENSE="GPL-3"
16 SLOT="0"
17 KEYWORDS="amd64 x86"
18
19 IUSE="aac flac libnotify mp3 ogg opus vorbis"
20 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
21
22 COMMON_DEPEND="${PYTHON_DEPS}
23         dev-libs/gobject-introspection:=
24         x11-libs/gtk+:3[introspection]
25         media-libs/gstreamer:1.0[introspection]
26 "
27
28 # gst-plugins-meta for any decoders, USE flags for specific encoders used by code
29 # List in soundconverter/gstreamer.py
30 # wavenc and mp4mux come from gst-plugins-good, which everyone having base should have, so unconditional
31 RDEPEND="${COMMON_DEPEND}
32         x11-libs/pango[introspection]
33         $(python_gen_cond_dep '
34                 dev-python/gst-python:1.0[${PYTHON_MULTI_USEDEP}]
35         ')
36         libnotify? ( x11-libs/libnotify[introspection] )
37
38         media-libs/gst-plugins-base:1.0[vorbis?,ogg?]
39         media-plugins/gst-plugins-meta:1.0
40         flac? ( media-plugins/gst-plugins-flac:1.0 )
41         media-libs/gst-plugins-good:1.0
42         mp3? (
43                 media-libs/gst-plugins-bad:1.0
44                 media-libs/gst-plugins-ugly:1.0
45                 media-plugins/gst-plugins-lame:1.0
46         )
47         aac? ( media-plugins/gst-plugins-faac:1.0 )
48         opus? ( media-plugins/gst-plugins-opus:1.0 )
49 "
50 DEPEND="${COMMON_DEPEND}
51         dev-util/intltool
52         sys-devel/gettext
53 "
54
55 RESTRICT="test" # broken pot files list in 3.0.0 release, making src_test fallback to "make test" which fails
56
57 src_prepare() {
58         python_fix_shebang .
59         gnome2_src_prepare
60 }
61
62 src_install() {
63         gnome2_src_install
64         python_optimize "${ED%/}"/usr/$(get_libdir)/soundconverter/python
65 }