media-sound/lollypop: python 3.{7,8} support
[gentoo.git] / media-sound / sndfile-tools / sndfile-tools-1.04.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DESCRIPTION="A small collection of programs that use libsndfile"
7 HOMEPAGE="http://www.mega-nerd.com/libsndfile/tools/"
8
9 if [[ ${PV} == *9999 ]]; then
10         inherit autotools git-r3
11         EGIT_REPO_URI="https://github.com/erikd/sndfile-tools.git"
12 else
13         SRC_URI="http://www.mega-nerd.com/libsndfile/files/${P}.tar.bz2"
14         KEYWORDS="~amd64"
15 fi
16
17 LICENSE="GPL-2"
18 SLOT="0"
19 IUSE="jack"
20
21 RDEPEND="
22         media-libs/libsndfile:=
23         media-libs/libsamplerate:=
24         x11-libs/cairo:=
25         sci-libs/fftw:3.0=
26         jack? ( media-sound/jack-audio-connection-kit:= )"
27 DEPEND="
28         virtual/pkgconfig
29         ${RDEPEND}"
30
31 src_prepare() {
32         default
33         [[ ${PV} == *9999 ]] && eautoreconf
34 }
35
36 src_configure() {
37         econf $(use_enable jack)
38 }