media-sound/pasystray: version bump to 0.6.0.
[gentoo.git] / media-sound / skype-call-recorder / skype-call-recorder-0.8.ebuild
1 # Copyright 1999-2013 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI="4"
6
7 inherit cmake-utils flag-o-matic
8
9 DESCRIPTION="Records Skype calls to MP3/Ogg/WAV files"
10 HOMEPAGE="http://atdot.ch/scr/"
11 SRC_URI="http://atdot.ch/scr/files/${PV}/${P}.tar.gz"
12
13 LICENSE="|| ( GPL-2 GPL-3 )"
14 KEYWORDS="~amd64 ~x86"
15 SLOT="0"
16 IUSE="debug"
17
18 DEPEND="
19         media-libs/id3lib
20         >=media-libs/libogg-1.2.0
21         >=media-libs/libvorbis-1.2.0
22         media-sound/lame
23         >=dev-qt/qtcore-4.4:4
24         >=dev-qt/qtdbus-4.4:4
25         >=dev-qt/qtgui-4.4:4
26 "
27 RDEPEND="${DEPEND}
28         net-im/skype[-qt-static(-)]
29 "
30
31 PATCHES=(
32         "${FILESDIR}/${P}-cmake.patch"
33 )
34
35 src_prepare() {
36         cmake-utils_src_prepare
37
38         append-ldflags $(no-as-needed) -lvorbis -logg # bug 482744
39 }