media-sound/jack2: removed obsolete 1.9.13-r2
[gentoo.git] / media-sound / shnflacverify / shnflacverify-0.3.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit eutils
7
8 DESCRIPTION="Manage the verification of checksums related to Shorten and FLAC files"
9 HOMEPAGE="https://sourceforge.net/projects/shnflacverify/"
10 SRC_URI="http://downloads.sourceforge.net/project/${PN}/${PN}/${P}/${P}.zip"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15
16 RDEPEND="
17         app-arch/unzip
18         dev-lang/perl
19         media-libs/flac
20         media-sound/shntool
21         sys-apps/coreutils"
22
23 S="${WORKDIR}"
24
25 src_prepare() {
26         default
27
28         edos2unix *.txt
29
30         local X
31         for X in flac md5sum shntool metaflac; do
32                 einfo "setting \$${X}_cmd to $(type -p ${X})"
33                 sed -i -e "s|^\(\$${X}_cmd\s*=\s*'\)[^']*\('.*\)|\1$(type -p ${X})\2|g" shnflac* || die
34         done
35 }
36
37 src_install() {
38         local X
39         for X in *.pl; do newbin "${X}" "${X%.*}"; done
40         newdoc README.txt README
41 }