media-sound/easytag: Stop demanding the dead dev-util/appdata-tools metapackage
[gentoo.git] / media-sound / sexypsf / sexypsf-0.4.7.ebuild
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 inherit eutils flag-o-matic
6
7 DESCRIPTION="sexyPSF is an open-source PSF1 (Playstation music) file player"
8 HOMEPAGE="http://projects.raphnet.net/#sexypsf"
9 SRC_URI="http://projects.raphnet.net/sexypsf/${P}.tar.bz2"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13
14 #-sparc: 0.4.5: Couldn't load minispf
15 KEYWORDS="amd64 ppc -sparc x86"
16 IUSE=""
17
18 DEPEND="sys-libs/zlib"
19
20 S=${WORKDIR}/${PN}
21
22 src_unpack() {
23         unpack ${A}
24         cd "${S}"
25         epatch "${FILESDIR}"/${P}-misc.patch
26
27         # ppc and sparc are big-endian while all other keywords are
28         # little-endian (as far as I know)
29         use ppc64 || use ppc || use sparc &&
30         sed -i -e "s:-D__LINUX__:& -DMSB_FIRST:" "${S}"/Linux/Makefile
31         # what about using the correct macro and avoid to cause severe damages to
32         # innocent ears?
33         sed -i -e "s:AFMT_S16_LE:AFMT_S16_NE:" "${S}"/Linux/oss.c
34 }
35
36 src_compile() {
37         cd "${S}"/Linux
38         emake || die "emake failed"
39 }
40
41 src_install() {
42         dobin Linux/sexypsf
43         dodoc Docs/*
44 }