media-sound/linuxsampler: Parallel build unsafe
[gentoo.git] / media-sound / setmixer / setmixer-19941227_p1.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=0
5
6 inherit eutils toolchain-funcs
7
8 MY_PV="27DEC94ds1"
9 DEB_REV="1"
10
11 DESCRIPTION="A commandline mixer"
12 HOMEPAGE="http://packages.debian.org/unstable/sound/setmixer"
13 SRC_URI="mirror://debian/pool/main/s/${PN}/${PN}_${MY_PV}.orig.tar.gz
14         mirror://debian/pool/main/s/${PN}/${PN}_${MY_PV}-${DEB_REV}.diff.gz"
15
16 LICENSE="GPL-2"
17 SLOT="0"
18 KEYWORDS="amd64 ~ppc sparc x86"
19 IUSE=""
20
21 S=${WORKDIR}/${PN}-${MY_PV}.orig
22
23 src_unpack() {
24         unpack ${A}
25         epatch "${DISTDIR}"/${PN}_${MY_PV}-${DEB_REV}.diff.gz
26 }
27
28 src_compile() {
29         emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" \
30                 LDFLAGS="${LDFLAGS}" setmixer || die "emake failed."
31 }
32
33 src_install() {
34         dobin setmixer
35         dodoc README setmixer.lsm
36         doman setmixer.1
37         insinto /etc
38         doins debian/setmixer.conf
39         newinitd "${FILESDIR}"/setmixer.rc setmixer
40 }