media-sound/alsa-utils: amd64 stable wrt bug #720810
[gentoo.git] / media-sound / seq24 / seq24-0.9.3-r1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit autotools desktop
7
8 DESCRIPTION="Loop based MIDI sequencer with focus on live performances"
9 HOMEPAGE="https://edge.launchpad.net/seq24/"
10 SRC_URI="https://edge.launchpad.net/seq24/trunk/${PV}/+download/${P}.tar.bz2"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="amd64 ~ppc x86"
15 IUSE="jack lash"
16
17 BDEPEND="
18         virtual/pkgconfig
19 "
20 DEPEND="
21         dev-cpp/gtkmm:2.4
22         dev-libs/libsigc++:2
23         media-libs/alsa-lib
24         jack? ( virtual/jack )
25         lash? ( media-sound/lash )
26 "
27 RDEPEND="${DEPEND}"
28
29 DOCS=( AUTHORS ChangeLog README RTC SEQ24 )
30
31 PATCHES=( "${FILESDIR}/${P}-std-mutex.patch" )
32
33 src_prepare() {
34         default
35         eautoreconf
36 }
37
38 src_configure() {
39         econf \
40                 $(use_enable jack) \
41                 $(use_enable lash)
42 }
43
44 src_install() {
45         default
46         newicon src/pixmaps/seq24_32.xpm seq24.xpm
47         make_desktop_entry seq24
48 }