Merge github#929: dev-util/idea-ultimate: Version bump to 15.0.4.
[gentoo.git] / media-sound / rgain / rgain-1.2.1.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 PYTHON_COMPAT=( python2_7 )
8
9 inherit distutils-r1
10
11 DESCRIPTION="Set of programmes and Python modules to deal with Replay Gain information"
12 HOMEPAGE="https://bitbucket.org/fk/rgain"
13 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
14
15 LICENSE="GPL-2"
16 SLOT="0"
17 KEYWORDS="~amd64 ~x86"
18 IUSE="flac mp3 vorbis wavpack"
19
20 DEPEND=">=dev-python/docutils-0.9"
21 RDEPEND="media-libs/mutagen
22         dev-python/pygobject:3[$PYTHON_USEDEP]
23         media-libs/gstreamer:1.0[introspection]
24         media-libs/gst-plugins-good:1.0
25         media-libs/gst-plugins-base:1.0[vorbis?]
26         flac? ( media-plugins/gst-plugins-flac:1.0 )
27         mp3? ( media-plugins/gst-plugins-mad:1.0 )
28         wavpack? ( media-plugins/gst-plugins-wavpack:1.0 )
29 "
30
31 src_install() {
32         distutils-r1_src_install
33         doman build/man/*
34 }