media-sound/strawberry: Removed old
[gentoo.git] / media-sound / qsampler / qsampler-0.5.6.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit qmake-utils xdg
7
8 DESCRIPTION="Graphical frontend to the LinuxSampler engine"
9 HOMEPAGE="https://qsampler.sourceforge.io/ https://www.linuxsampler.org/"
10 SRC_URI="mirror://sourceforge/${PN}/${PV}/${P}.tar.gz"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="amd64 ~x86"
15 IUSE="debug +libgig"
16
17 COMMON_DEPEND="
18         dev-qt/qtcore:5
19         dev-qt/qtgui:5
20         dev-qt/qtwidgets:5
21         dev-qt/qtx11extras:5
22         media-libs/alsa-lib
23         >=media-libs/liblscp-0.5.6:=
24         x11-libs/libX11
25         libgig? ( >=media-libs/libgig-3.3.0:= )
26 "
27 RDEPEND="${COMMON_DEPEND}
28         >=media-sound/linuxsampler-0.5
29 "
30 DEPEND="${COMMON_DEPEND}
31         dev-qt/linguist-tools:5
32 "
33
34 DOCS=( AUTHORS ChangeLog README TODO TRANSLATORS )
35
36 PATCHES=( "${FILESDIR}/${PN}-0.5.3-Makefile.patch" )
37
38 src_configure() {
39         local myeconfargs=(
40                 $(use_enable debug)
41                 $(use_enable libgig)
42         )
43         ac_qmake="$(qt5_get_bindir)/qmake" \
44                 econf "${myeconfargs[@]}"
45
46         cd src || die
47         eqmake5 src.pro -o Makefile
48 }