media-sound/pasystray: version bump to 0.6.0.
[gentoo.git] / media-sound / qmpdclient / qmpdclient-1.2.2-r1.ebuild
1 # Copyright 1999-2013 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=4
6 inherit fdo-mime cmake-utils
7
8 DESCRIPTION="QMPDClient with NBL additions, such as lyrics' display"
9 HOMEPAGE="http://bitcheese.net/wiki/QMPDClient"
10 SRC_URI="http://dump.bitcheese.net/files/${P}.tar.bz2"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS=""
15 KEYWORDS="amd64 ppc x86"
16 IUSE="debug"
17
18 DEPEND="dev-qt/qtdbus:4
19         dev-qt/qtgui:4
20         dev-qt/qtwebkit:4
21         dev-qt/qtxmlpatterns:4"
22 RDEPEND="${DEPEND}"
23
24 S=${WORKDIR}/${PN}
25
26 DOCS=( AUTHORS README THANKSTO )
27 PATCHES=( "${FILESDIR}"/${P}-qt48.patch )
28
29 src_prepare() {
30         sed -i -e "/^Categories/s/Network/AudioVideo/" ${PN}.desktop || die
31         cmake-utils_src_prepare
32 }
33
34 src_configure() {
35         local mycmakeargs=( "-DVERSION=${PV}" )
36         cmake-utils_src_configure
37 }
38
39 pkg_postinst() { fdo-mime_desktop_database_update; }
40 pkg_postrm() { fdo-mime_desktop_database_update; }