media-sound/strawberry: Bump to version 0.6.10
[gentoo.git] / media-sound / qjackctl / qjackctl-0.6.1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit flag-o-matic qmake-utils xdg-utils
7
8 DESCRIPTION="Qt GUI to control the JACK Audio Connection Kit and ALSA sequencer connections"
9 HOMEPAGE="https://qjackctl.sourceforge.io/"
10 SRC_URI="mirror://sourceforge/qjackctl/${P}.tar.gz"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="amd64 x86"
15
16 IUSE="alsa dbus debug portaudio"
17
18 RDEPEND="
19         app-arch/gzip
20         dev-qt/qtcore:5
21         dev-qt/qtgui:5
22         dev-qt/qtwidgets:5
23         dev-qt/qtx11extras:5
24         dev-qt/qtxml:5
25         virtual/jack
26         alsa? ( media-libs/alsa-lib )
27         dbus? ( dev-qt/qtdbus:5 )
28         portaudio? ( media-libs/portaudio )"
29 DEPEND="${RDEPEND}
30         dev-qt/linguist-tools:5"
31
32 src_configure() {
33         append-cxxflags -std=c++11
34         econf \
35                 $(use_enable alsa alsa-seq) \
36                 $(use_enable dbus) \
37                 $(use_enable debug) \
38                 $(use_enable portaudio) \
39                 --enable-jack-version
40
41         eqmake5 ${PN}.pro -o ${PN}.mak
42 }
43
44 src_compile() {
45         emake -f ${PN}.mak
46 }
47
48 src_install() {
49         default
50
51         gunzip "${D}/usr/share/man/man1/qjackctl.fr.1.gz"
52         gunzip "${D}/usr/share/man/man1/qjackctl.1.gz"
53 }
54
55 pkg_postinst() {
56         xdg_icon_cache_update
57 }
58
59 pkg_postrm() {
60         xdg_icon_cache_update
61 }