media-sound/hydrogen: updated digest for 1.0.0_beta2
[gentoo.git] / media-sound / pulseaudio-modules-bt / pulseaudio-modules-bt-9999.ebuild
1 # Copyright 2019-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit git-r3 cmake-utils readme.gentoo-r1
7
8 DESCRIPTION="PulseAudio modules for LDAC, aptX, aptX HD, and AAC for Bluetooth"
9 HOMEPAGE="https://github.com/EHfive/pulseaudio-modules-bt"
10 SRC_URI=""
11 EGIT_REPO_URI="https://github.com/EHfive/${PN}"
12
13 # Ensure it is synced with major pulseaudio version
14 # https://github.com/EHfive/pulseaudio-modules-bt/issues/83
15 EGIT_OVERRIDE_COMMIT_PULSEAUDIO_PULSEAUDIO="v13.0"
16
17 LICENSE="GPL-3"
18 SLOT="0"
19 KEYWORDS=""
20 IUSE="fdk +ffmpeg +ldac +native-headset ofono-headset"
21
22 DEPEND="
23         fdk? ( media-libs/fdk-aac:0= )
24         ffmpeg? ( media-video/ffmpeg )
25         media-libs/sbc
26         ldac? ( media-libs/libldac )
27         >=net-wireless/bluez-5
28         >=sys-apps/dbus-1.0.0
29         ofono-headset? ( >=net-misc/ofono-1.13 )
30         >=media-sound/pulseaudio-13[-bluetooth]
31 "
32 # Ordinarily media-libs/libldac should be in DEPEND too, but for now upstream repo is using a ldac submodule instead.
33
34 RDEPEND="${DEPEND}"
35 BDEPEND=""
36
37 CMAKE_MAKEFILE_GENERATOR="emake"
38
39 DISABLE_AUTOFORMATTING="no"
40 DOC_CONTENTS="
41 After getting media-sound/pulseaudio merged without its bluetooth
42 support (to not collide with this) you may have removed the loading
43 of bluetooth modules in default.pa config file, leading to failure
44 to use your bluetooth device (see
45 https://github.com/EHfive/pulseaudio-modules-bt/issues/33).
46 Please ensure you have this lines present in your /etc/pulse/default.pa
47 file:
48
49 .ifexists module-bluetooth-policy.so
50 load-module module-bluetooth-policy
51 .endif
52
53 .ifexists module-bluetooth-discover.so
54 load-module module-bluetooth-discover
55 .endif
56 "
57
58 src_configure() {
59         local mycmakeargs=(
60                 -DCODEC_AAC_FDK=$(usex fdk "ON" "OFF")
61                 -DCODEC_APTX_FF=$(usex ffmpeg "ON" "OFF")
62                 -DCODEC_APTX_HD_FF=$(usex ffmpeg "ON" "OFF")
63                 -DCODEC_LDAC=$(usex ldac "ON" "OFF")
64                 -DNATIVE_HEADSET=$(usex native-headset "ON" "OFF")
65                 -DOFONO_HEADSET=$(usex ofono-headset "ON" "OFF")
66         )
67         cmake-utils_src_configure
68 }
69
70 src_install() {
71         cmake-utils_src_install
72         readme.gentoo_create_doc
73 }
74
75 pkg_postinst() {
76         readme.gentoo_print_elog
77 }