media-sound/mumble: Bump to version 1.3.1_rc1
[gentoo.git] / media-sound / ptabtools / ptabtools-0.5.0.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit toolchain-funcs
7
8 DESCRIPTION="Utilities for PowerTab Guitar files (.ptb)"
9 HOMEPAGE="https://www.samba.org/~jelmer/ptabtools/"
10 SRC_URI="https://www.samba.org/~jelmer/${PN}/${P}.tar.gz"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~amd64 ~ppc x86"
15 IUSE=""
16
17 RDEPEND="
18         dev-libs/popt:=
19         dev-libs/libxml2:=
20         dev-libs/libxslt:="
21 DEPEND="${RDEPEND}"
22 BDEPEND="virtual/pkgconfig"
23
24 PATCHES=( "${FILESDIR}"/${P}-makefile.patch )
25
26 src_compile() {
27         emake AR=$(tc-getAR)
28 }
29
30 src_install() {
31         emake DESTDIR="${D}" libdir="/usr/$(get_libdir)" install
32         einstalldocs
33
34         # QA Notice: Missing soname symlink(s):
35         #     usr/lib64/libptb.so.0 -> libptb.so.0.5.0
36         dosym libptb.so.0.5.0 /usr/$(get_libdir)/libptb.so.0
37
38         # Don't want static archives
39         find "${D}" -name '*.a' -delete || die
40 }