media-sound/strawberry: Removed old
[gentoo.git] / media-sound / potamus / potamus-16.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 inherit gnome2
6
7 DESCRIPTION="A lightweight audio player with a simple interface and an emphasis on high audio quality"
8 HOMEPAGE="http://offog.org/code/potamus/"
9 SRC_URI="http://offog.org/files/${P}.tar.gz"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~amd64 ~ppc ~x86"
14 IUSE="+ao audiofile flac jack mad modplug opus vorbis"
15
16 RDEPEND="
17         x11-libs/gtk+:2
18         >=gnome-base/libglade-2
19         media-libs/libsamplerate
20         ao? ( media-libs/libao )
21         audiofile? ( media-libs/audiofile )
22         flac? ( media-libs/flac )
23         jack? ( media-sound/jack-audio-connection-kit )
24         >=media-video/ffmpeg-2.8:0=
25         mad? ( media-libs/libmad )
26         modplug? ( media-libs/libmodplug )
27         opus? ( media-libs/opusfile )
28         vorbis? ( media-libs/libvorbis )
29 "
30 DEPEND="${RDEPEND}
31         virtual/pkgconfig
32 "
33
34 PATCHES=( "${FILESDIR}/ffmpeg29.patch" )
35
36 src_configure() {
37         gnome2_src_configure \
38                 $(use_enable audiofile input-audiofile) \
39                 $(use_enable flac input-flac) \
40                 $(use_enable mad input-mad) \
41                 $(use_enable modplug input-modplug) \
42                 $(use_enable opus input-opus) \
43                 $(use_enable vorbis input-vorbis) \
44                 $(use_enable ao output-ao) \
45                 $(use_enable jack output-jack)
46
47 }