media-sound/qsynth: x86 stable wrt bug #720454
[gentoo.git] / media-sound / podracer / podracer-1.4-r2.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DESCRIPTION="A simple podcast aggregator, designed for cron"
7 HOMEPAGE="http://podracer.sourceforge.net/"
8 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
9
10 LICENSE="MIT"
11 SLOT="0"
12 KEYWORDS="amd64 x86"
13 IUSE=""
14
15 DEPEND=""
16 RDEPEND="app-shells/bash
17         net-misc/curl"
18
19 src_unpack() {
20         default
21
22         # Bug 619956. Change directories first to ensure that "unpack" outputs
23         # to ${S} and not to ${WORKDIR}.
24         cd "${S}" || die
25         unpack "${S}/podracer.1.gz"
26 }
27
28 src_install() {
29         dobin podracer
30         sed -i -e "s:sample=/usr/share/doc/\$progname/sample.subscriptions:sample=/usr/share/doc/${PF}/sample.subscriptions:" "${D}"/usr/bin/podracer || die
31         dodoc CREDITS README ChangeLog TODO
32         doman podracer.1
33         docompress -x "/usr/share/doc/${PF}/sample.subscriptions"
34         dodoc sample.subscriptions
35         insinto /etc/
36         doins podracer.conf
37 }