media-sound/hydrogen: stable 1.0.0_beta2 for ppc, bug #719012
[gentoo.git] / media-sound / pnmixer / pnmixer-9999.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 WANT_LIBTOOL=none
7 inherit cmake-utils gnome2-utils git-r3
8
9 DESCRIPTION="Volume mixer for the system tray"
10 HOMEPAGE="https://github.com/nicklan/pnmixer"
11 EGIT_REPO_URI="git@github.com:nicklan/pnmixer.git
12         https://github.com/nicklan/pnmixer.git"
13 EGIT_BRANCH="master"
14
15 LICENSE="GPL-3"
16 SLOT="0"
17 KEYWORDS=""
18 IUSE="libnotify"
19
20 RDEPEND="dev-libs/glib:2
21         media-libs/alsa-lib
22         >=x11-libs/gtk+-3.12:3
23         x11-libs/libX11
24         libnotify? ( x11-libs/libnotify )"
25 DEPEND="${RDEPEND}
26         sys-devel/gettext
27         virtual/pkgconfig"
28
29 src_configure() {
30         local mycmakeargs=(
31                 -DWITH_LIBNOTIFY="$(usex libnotify)"
32         )
33
34         cmake-utils_src_configure
35 }
36
37 pkg_postinst() {
38         gnome2_icon_cache_update
39 }
40
41 pkg_postrm() {
42         gnome2_icon_cache_update
43 }