media-libs/portaudio: Version bump
[gentoo.git] / media-sound / picard / picard-1.3.2-r1.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 PYTHON_COMPAT=( python2_7 )
7 DISTUTILS_SINGLE_IMPL=1
8 DISABLE_AUTOFORMATTING=true
9 inherit eutils distutils-r1 readme.gentoo
10
11 DESCRIPTION="A cross-platform music tagger"
12 HOMEPAGE="http://picard.musicbrainz.org/"
13 SRC_URI="http://ftp.musicbrainz.org/pub/musicbrainz/picard/${P}.tar.gz"
14
15 LICENSE="GPL-2"
16 SLOT="0"
17 KEYWORDS="amd64 ~ppc x86"
18 IUSE="+acoustid +cdda nls"
19
20 DEPEND="dev-python/PyQt4[X,${PYTHON_USEDEP}]
21         dev-qt/qtgui:4[accessibility]
22         media-libs/mutagen
23         acoustid? ( >=media-libs/chromaprint-1.0[tools] )
24         cdda? ( dev-python/python-discid )"
25 RDEPEND="${DEPEND}"
26
27 RESTRICT="test" # doesn't work with ebuilds
28 S=${WORKDIR}/${PN}-release-${PV}
29 DOCS="AUTHORS.txt NEWS.txt"
30
31 DOC_CONTENTS="If you are upgrading Picard and it does not start,
32 try removing Picard's settings:
33     rm ~/.config/MusicBrainz/Picard.conf
34
35 You should set the environment variable BROWSER to something like
36     firefox '%s' &
37 to let python know which browser to use."
38
39 src_compile() {
40         distutils-r1_src_compile $(use nls || echo "--disable-locales")
41 }
42
43 src_install() {
44         distutils-r1_src_install --disable-autoupdate --skip-build \
45                 $(use nls || echo "--disable-locales")
46
47         doicon picard.ico
48         domenu picard.desktop
49         readme.gentoo_create_doc
50 }