media-libs/portaudio: Version bump
[gentoo.git] / media-sound / picard / picard-1.3.1.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 PYTHON_COMPAT=( python2_7 )
7 DISTUTILS_SINGLE_IMPL=1
8 DISABLE_AUTOFORMATTING=true
9 inherit eutils distutils-r1 readme.gentoo
10
11 DESCRIPTION="A cross-platform music tagger"
12 HOMEPAGE="http://picard.musicbrainz.org/"
13 SRC_URI="http://ftp.musicbrainz.org/pub/musicbrainz/picard/${P}.tar.gz"
14
15 LICENSE="GPL-2"
16 SLOT="0"
17 KEYWORDS="amd64 ~ppc x86"
18 IUSE="+acoustid +cdda nls"
19
20 DEPEND="dev-python/PyQt4[X,${PYTHON_USEDEP}]
21         media-libs/mutagen
22         acoustid? ( >=media-libs/chromaprint-1.0[tools] )
23         cdda? ( >=media-libs/libdiscid-0.1.1 )"
24 RDEPEND="${DEPEND}"
25
26 RESTRICT="test" # doesn't work with ebuilds
27 S=${WORKDIR}/${PN}-release-${PV}
28 DOCS="AUTHORS.txt NEWS.txt"
29
30 DOC_CONTENTS="If you are upgrading Picard and it does not start,
31 try removing Picard's settings:
32     rm ~/.config/MusicBrainz/Picard.conf
33
34 You should set the environment variable BROWSER to something like
35     firefox '%s' &
36 to let python know which browser to use."
37
38 src_compile() {
39         distutils-r1_src_compile $(use nls || echo "--disable-locales")
40 }
41
42 src_install() {
43         distutils-r1_src_install --disable-autoupdate --skip-build \
44                 $(use nls || echo "--disable-locales")
45
46         doicon picard.ico
47         domenu picard.desktop
48         readme.gentoo_create_doc
49 }