media-sound/alsa-utils: stable 1.2.2 for ppc64, bug #720810
[gentoo.git] / media-sound / pavucontrol / pavucontrol-3.0.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 inherit flag-o-matic
6
7 DESCRIPTION="Pulseaudio Volume Control, GTK based mixer for Pulseaudio"
8 HOMEPAGE="https://freedesktop.org/software/pulseaudio/pavucontrol/"
9 SRC_URI="https://freedesktop.org/software/pulseaudio/${PN}/${P}.tar.xz"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="amd64 ~arm64 ppc ~ppc64 ~sparc x86"
14 IUSE="nls"
15
16 RDEPEND="
17         >=dev-cpp/gtkmm-3.0:3.0
18         >=dev-libs/libsigc++-2.2:2
19         >=media-libs/libcanberra-0.16[gtk3]
20         >=media-sound/pulseaudio-3[glib]
21         virtual/freedesktop-icon-theme
22 "
23 DEPEND="${RDEPEND}
24         virtual/pkgconfig
25         nls? (
26                 dev-util/intltool
27                 sys-devel/gettext
28         )
29 "
30
31 src_configure() {
32         append-cxxflags -std=c++11 #567216
33         econf \
34                 --docdir=/usr/share/doc/${PF} \
35                 --htmldir=/usr/share/doc/${PF}/html \
36                 --disable-lynx \
37                 $(use_enable nls)
38 }