media-sound/pasystray: version bump to 0.6.0.
[gentoo.git] / media-sound / pasystray / pasystray-0.2.1.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=4
6 inherit gnome2-utils
7
8 DESCRIPTION="A system tray for pulseaudio controls (replacement for the deprecated padevchooser)"
9 HOMEPAGE="https://github.com/christophgysin/pasystray"
10 SRC_URI="mirror://github/christophgysin/${PN}/${P}.tar.bz2"
11
12 LICENSE="LGPL-2.1"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE="libnotify"
16
17 RDEPEND="
18         || ( >=media-sound/pulseaudio-1.0[glib,avahi] >=media-sound/pulseaudio-5.0-r3[glib,zeroconf] )
19         >=net-dns/avahi-0.6
20         x11-libs/gtk+:3
21         x11-libs/libX11
22         libnotify? ( >=x11-libs/libnotify-0.7 )
23 "
24 DEPEND="${RDEPEND}
25         virtual/pkgconfig"
26
27 DOCS="AUTHORS README TODO"
28
29 src_configure() {
30         econf $(use_enable libnotify notify)
31 }
32
33 pkg_preinst() { gnome2_icon_savelist; }
34 pkg_postinst() { gnome2_icon_cache_update; }
35 pkg_postrm() { gnome2_icon_cache_update; }