media-sound/alsa-tools: stable 1.2.2-r1 for ppc, bug #720810
[gentoo.git] / media-sound / pamix / pamix-9999.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit cmake
7
8 if [[ "${PV}" == 9999 ]] ; then
9         inherit git-r3
10 fi
11
12 DESCRIPTION="A PulseAudio NCurses mixer"
13 HOMEPAGE="https://github.com/patroclos/PAmix"
14 LICENSE="MIT"
15 SLOT="0"
16 IUSE="+unicode"
17
18 if [[ ${PV} == 9999 ]] ; then
19         EGIT_REPO_URI="https://github.com/patroclos/PAmix.git"
20 else
21         SRC_URI="https://github.com/patroclos/PAmix/archive/v${PV}.tar.gz -> ${P}.tar.gz"
22         KEYWORDS="~amd64 ~x86"
23         S="${WORKDIR}/PAmix-${PV}"
24 fi
25
26 RDEPEND="media-sound/pulseaudio
27         sys-libs/ncurses:0=[unicode?]"
28 DEPEND="${RDEPEND}"
29 BDEPEND="
30         virtual/pkgconfig
31 "
32
33 src_configure() {
34         local mycmakeargs=(
35                 -DWITH_UNICODE="$(usex unicode)"
36         )
37         cmake_src_configure
38 }