media-sound/qsynth: x86 stable wrt bug #720454
[gentoo.git] / media-sound / pamix / pamix-1.5.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 SCM=""
7 [[ "${PV}" == 9999 ]] && SCM="git-r3"
8 inherit autotools ${SCM}
9 unset SCM
10
11 DESCRIPTION="A PulseAudio NCurses mixer"
12 HOMEPAGE="https://github.com/patroclos/PAmix"
13 LICENSE="MIT"
14 SLOT="0"
15 IUSE="+unicode"
16
17 if [[ ${PV} == 9999 ]] ; then
18         EGIT_REPO_URI="https://github.com/patroclos/PAmix.git"
19 else
20         SRC_URI="https://github.com/patroclos/PAmix/archive/${PV}.tar.gz -> ${P}.tar.gz"
21         KEYWORDS="amd64 x86"
22         S="${WORKDIR}/PAmix-${PV}"
23 fi
24
25 RDEPEND="media-sound/pulseaudio
26         sys-libs/ncurses:0=[unicode?]"
27 DEPEND="sys-devel/autoconf-archive
28         virtual/pkgconfig
29         ${RDEPEND}"
30
31 src_prepare() {
32         default
33         eautoreconf
34 }
35
36 src_configure() {
37         econf $(use_enable unicode)
38 }