media-sound/ardour: version bump to 6.0
[gentoo.git] / media-sound / opus-tools / opus-tools-0.2.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 inherit autotools
6
7 DESCRIPTION="Royalty-free, highly versatile audio codec"
8 HOMEPAGE="https://opus-codec.org/"
9
10 if [[ ${PV} == *9999 ]] ; then
11         inherit git-r3
12         EGIT_REPO_URI="https://git.xiph.org/opus-tools.git"
13 elif [[ ${PV%_p*} != ${PV} ]] ; then # Gentoo snapshot
14         SRC_URI="https://dev.gentoo.org/~lu_zero/${PN}/${P}.tar.xz"
15 else # Official release
16         SRC_URI="https://downloads.xiph.org/releases/opus/${P}.tar.gz"
17 fi
18
19 LICENSE="BSD-2"
20 SLOT="0"
21 KEYWORDS="amd64 ppc ppc64 x86"
22 IUSE="flac"
23
24 RDEPEND="
25         >=media-libs/libogg-1.3.0
26         >=media-libs/libopusenc-0.2
27         >=media-libs/opus-1.1
28         >=media-libs/opusfile-0.5
29         flac? ( >=media-libs/flac-1.1.3 )
30 "
31 DEPEND="${RDEPEND}"
32 BDEPEND="virtual/pkgconfig"
33
34 src_prepare() {
35         default
36         [[ ${PV} == *9999 ]] && eautoreconf
37 }
38
39 src_configure() {
40         econf $(use_with flac)
41 }
42
43 src_install() {
44         default
45         find "${ED}" \( -name "*.a" -o -name "*.la" \) -delete || die
46 }