*/*: [QA] Remove redundant --docdir/--htmldir
[gentoo.git] / media-sound / ncmpcpp / ncmpcpp-0.7.7.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DESCRIPTION="featureful ncurses based MPD client inspired by ncmpc"
7 HOMEPAGE="https://rybczak.net/ncmpcpp/"
8 SRC_URI="https://rybczak.net/ncmpcpp/stable/${P}.tar.bz2"
9
10 LICENSE="GPL-2"
11 SLOT="0"
12 KEYWORDS="amd64 arm hppa ppc ppc64 sparc x86"
13 IUSE="clock curl outputs taglib visualizer"
14
15 RDEPEND="
16         !dev-libs/boost:0/1.57.0
17         >=media-libs/libmpdclient-2.1
18         dev-libs/boost:=[icu]
19         dev-libs/boost:=[nls,threads]
20         dev-libs/icu:=
21         sys-libs/ncurses:=[unicode]
22         sys-libs/readline:*
23         curl? ( net-misc/curl )
24         taglib? ( media-libs/taglib )
25         visualizer? ( sci-libs/fftw:3.0= )
26 "
27 DEPEND="
28         ${RDEPEND}
29         virtual/pkgconfig
30 "
31
32 src_prepare() {
33         default
34
35         sed -i -e '/^docdir/d' {,doc/}Makefile{.am,.in} || die
36         sed -i -e 's|COPYING||g' Makefile{.am,.in} || die
37 }
38
39 src_configure() {
40         econf \
41                 $(use_enable clock) \
42                 $(use_enable outputs) \
43                 $(use_enable visualizer) \
44                 $(use_with curl) \
45                 $(use_with taglib) \
46                 $(use_with visualizer fftw) \
47                 --enable-unicode
48 }
49
50 src_install() {
51         default
52
53         dodoc doc/{bindings,config}
54 }
55
56 pkg_postinst() {
57         echo
58         elog "Example configuration files have been installed at"
59         elog "${ROOT}usr/share/doc/${PF}"
60         elog "${P} uses ~/.ncmpcpp/config and ~/.ncmpcpp/bindings"
61         elog "as user configuration files."
62         echo
63         if use visualizer; then
64         elog "If you want to use the visualizer, you need mpd with fifo enabled."
65         echo
66         fi
67 }