media-sound/teamspeak-server: amd64 stable wrt bug #724112
[gentoo.git] / media-sound / muse / muse-0.9.2_p20161002.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit autotools
7
8 DESCRIPTION="Multiple Streaming Engine, an icecast source streamer"
9 HOMEPAGE="http://muse.dyne.org"
10 SRC_URI="https://dev.gentoo.org/~soap/distfiles/${P}.tar.gz"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~amd64 ~ppc ~sparc ~x86"
15 IUSE="doc gtk jack ncurses portaudio"
16
17 RDEPEND="media-sound/lame
18         media-libs/libvorbis
19         media-libs/libsndfile
20         media-libs/libogg
21         media-libs/libshout
22         media-libs/libsamplerate
23         gtk? ( x11-libs/gtk+:2 )
24         jack? ( media-sound/jack-audio-connection-kit )
25         ncurses? ( sys-libs/ncurses:0= )
26         portaudio? ( media-libs/portaudio )
27 "
28 DEPEND="${RDEPEND}
29         virtual/pkgconfig
30         doc? ( app-doc/doxygen )"
31
32 PATCHES=(
33         "${FILESDIR}"/${PN}-0.9.2_p20161002-fix-build-system.patch
34 )
35
36 src_prepare() {
37         default
38         eautoreconf
39 }
40
41 src_configure() {
42         econf \
43                 --without-dmalloc \
44                 --disable-profiling \
45                 --disable-lubrify \
46                 $(use_enable gtk gtk2) \
47                 $(use_enable jack) \
48                 $(use_enable ncurses) \
49                 $(use_enable portaudio) \
50                 $(use_enable doc)
51 }