Merge remote-tracking branch 'github/pr/372'.
[gentoo.git] / media-sound / mpfc / mpfc-1.3.8.1-r1.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 DESCRIPTION="Music Player For Console"
8 HOMEPAGE="http://mpfc.sourceforge.net/"
9 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~amd64 ~ppc ~x86"
14 IUSE="alsa cdda flac gpm mad nls oss static-libs vorbis wav"
15
16 RDEPEND="alsa? ( >=media-libs/alsa-lib-0.9.0 )
17         flac? ( media-libs/flac )
18         gpm? ( >=sys-libs/gpm-1.19.3 )
19         mad? ( media-libs/libmad )
20         vorbis? ( media-libs/libvorbis )
21         sys-libs/ncurses[unicode]
22         dev-libs/icu:="
23 DEPEND="${RDEPEND}"
24
25 src_configure() {
26         econf \
27                 $(use_enable alsa) \
28                 $(use_enable cdda audiocd) \
29                 $(use_enable flac) \
30                 $(use_enable gpm) \
31                 $(use_enable mad mp3) \
32                 $(use_enable nls) \
33                 $(use_enable oss) \
34                 $(use_enable static-libs static) \
35                 $(use_enable vorbis ogg) \
36                 $(use_enable wav)
37 }
38
39 src_install() {
40         default
41
42         insinto /etc
43         doins mpfcrc
44
45         find "${D}" -name '*.la' -delete || die
46 }