x11-terms/mate-terminal: Fix LICENSE
[gentoo.git] / media-sound / mpdscribble / mpdscribble-9999.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit git-r3 autotools
7
8 DESCRIPTION="An MPD client that submits information to Audioscrobbler"
9 HOMEPAGE="https://www.musicpd.org/clients/mpdscribble/"
10 EGIT_REPO_URI="https://github.com/MusicPlayerDaemon/mpdscribble.git"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS=""
15 IUSE="+curl"
16
17 RDEPEND="dev-libs/glib:2
18         media-libs/libmpdclient
19         curl? ( net-misc/curl )
20         !curl? ( net-libs/libsoup:2.4 )"
21 DEPEND="${RDEPEND}
22         virtual/pkgconfig"
23
24 src_prepare() {
25         default
26         eautoreconf
27 }
28
29 src_configure() {
30         econf \
31                 --with-http-client=$(usex curl curl soup)
32 }
33
34 src_install() {
35         default
36         newinitd "${FILESDIR}/mpdscribble.rc" mpdscribble
37         keepdir /var/cache/mpdscribble
38 }