media-sound/teamspeak-server: drop old version
[gentoo.git] / media-sound / mpdscribble / mpdscribble-0.22.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DESCRIPTION="An MPD client that submits information to Audioscrobbler"
7 HOMEPAGE="https://www.musicpd.org/clients/mpdscribble/"
8 SRC_URI="https://www.musicpd.org/download/${PN}/${PV}/${P}.tar.bz2"
9
10 LICENSE="GPL-2"
11 SLOT="0"
12 KEYWORDS="amd64 ~ppc x86"
13 IUSE="+curl"
14
15 RDEPEND="dev-libs/glib:2
16         media-libs/libmpdclient
17         curl? ( net-misc/curl )
18         !curl? ( net-libs/libsoup:2.4 )"
19 DEPEND="${RDEPEND}
20         virtual/pkgconfig"
21
22 src_configure() {
23         econf \
24                 --with-http-client=$(usex curl curl soup)
25 }
26
27 src_install() {
28         default
29         newinitd "${FILESDIR}/mpdscribble.rc" mpdscribble
30         keepdir /var/cache/mpdscribble
31 }