media-sound/qjackctl: x86 stable wrt bug #720424
[gentoo.git] / media-sound / mpdas / mpdas-0.4.2.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit toolchain-funcs
7
8 DESCRIPTION="AudioScrobbler client for MPD written in C++"
9 HOMEPAGE="https://50hz.ws/mpdas/"
10 SRC_URI="https://50hz.ws/${PN}/${P}.tar.gz"
11
12 LICENSE="BSD"
13 SLOT="0"
14 KEYWORDS="amd64 x86"
15 IUSE=""
16
17 BDEPEND="
18         virtual/pkgconfig
19 "
20 DEPEND="
21         media-libs/libmpdclient
22         net-misc/curl"
23 RDEPEND="${DEPEND}"
24
25 src_prepare() {
26         default
27         sed -i -e 's/@//' Makefile || die
28 }
29
30 src_compile() {
31         tc-export CXX
32         emake CONFIG="/etc"
33 }
34
35 src_install() {
36         dobin ${PN}
37         doman ${PN}.1
38         newinitd "${FILESDIR}/${PN}.init" ${PN}
39         dodoc mpdasrc.example README
40 }
41
42 pkg_postinst() {
43         elog "For further configuration help consult the README in"
44         elog "${EPREFIX}/usr/share/doc/${PF}"
45 }