media-sound/teamspeak-server: amd64 stable wrt bug #724112
[gentoo.git] / media-sound / mp3gain / mp3gain-1.6.1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 inherit toolchain-funcs
6
7 MY_P="${P//./_}"
8
9 DESCRIPTION="A program to analyze and adjust MP3 files to same volume"
10 HOMEPAGE="http://mp3gain.sourceforge.net/"
11 SRC_URI="mirror://sourceforge/${PN}/${MY_P}-src.zip"
12
13 LICENSE="LGPL-2.1"
14 SLOT="0"
15 KEYWORDS="~alpha amd64 ~hppa ~ppc ~ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
16 IUSE=""
17
18 RDEPEND="
19         app-arch/unzip
20         media-sound/mpg123
21 "
22 DEPEND="${RDEPEND}"
23
24 PATCHES=( "${FILESDIR}"/${P}-CVE-2017-12911.patch )
25
26 S="${WORKDIR}"
27
28 src_compile() {
29         emake CC="$(tc-getCC)"
30 }
31
32 src_install() {
33         dobin mp3gain
34 }