dev-cpp/pangomm: stable 2.42.1 for hppa, bug #717144
[gentoo.git] / media-sound / mp3check / mp3check-0.8.7.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit flag-o-matic toolchain-funcs
7
8 DESCRIPTION="Checks mp3 files for consistency and prints several errors and warnings"
9 HOMEPAGE="https://code.google.com/p/mp3check/"
10 SRC_URI="https://${PN}.googlecode.com/files/${P}.tgz"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="amd64 ~ppc x86"
15
16 PATCHES=(
17         "${FILESDIR}"/${PN}-0.8.7-fix-buildsystem.patch
18         "${FILESDIR}"/${PN}-0.8.7-fix-c++14-operator-delete.patch
19 )
20
21 src_configure() {
22         # tfiletools.h:59:50: warning: dereferencing type-punned pointer will break
23         # strict-aliasing rules [-Wstrict-aliasing]
24         append-cxxflags -fno-strict-aliasing
25
26         tc-export CXX
27 }
28
29 src_install() {
30         dobin ${PN}
31         doman *.1
32 }