media-sound/strawberry: Synced live ebuild
[gentoo.git] / media-sound / mp32ogg / mp32ogg-0.11-r6.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DESCRIPTION="A perl script to convert MP3 files to Ogg Vorbis files"
7 HOMEPAGE="http://faceprint.com/code/"
8 SRC_URI="ftp://ftp.faceprint.com/pub/software/scripts/mp32ogg"
9
10 LICENSE="Artistic"
11 SLOT="0"
12 KEYWORDS="amd64 x86"
13 IUSE=""
14
15 RDEPEND="media-sound/mpg123
16         dev-perl/MP3-Info
17         dev-perl/String-ShellQuote
18         media-sound/vorbis-tools"
19 DEPEND=""
20
21 S=${WORKDIR}
22
23 PATCHES=(
24         "${FILESDIR}/${P}-r4-mpg321.patch"
25         "${FILESDIR}/${P}-r4-quality.patch"\
26         "${FILESDIR}/${P}-r5-german_umlaut.patch"
27         "${FILESDIR}/${P}-r6-force-filename-stringification.patch"
28 )
29
30 src_unpack() {
31         cp -f "${DISTDIR}"/${PN} "${WORKDIR}" || die "Copying sources failed"
32 }
33
34 src_install() {
35         dobin mp32ogg
36 }