media-sound/ncmpcpp: fix build with GCC 10
[gentoo.git] / media-sound / meterbridge / meterbridge-0.9.3.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit autotools
7
8 DESCRIPTION="Software meterbridge for the UNIX based JACK audio system"
9 HOMEPAGE="http://plugin.org.uk/meterbridge/"
10 SRC_URI="http://plugin.org.uk/meterbridge/${P}.tar.gz"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="amd64 ppc x86"
15 IUSE=""
16
17 BDEPEND="
18         virtual/pkgconfig
19 "
20 RDEPEND="
21         >=media-libs/libsdl-1.2
22         >=media-libs/sdl-image-1.2.10[png]
23         virtual/jack
24         virtual/opengl
25 "
26 DEPEND="${RDEPEND}"
27
28 PATCHES=(
29         "${FILESDIR}/${P}-gcc41.patch"
30         "${FILESDIR}/${P}-asneeded.patch"
31         "${FILESDIR}/${P}-cflags.patch"
32         "${FILESDIR}/${P}-setrgba.patch"
33 )
34
35 src_prepare() {
36         default
37         eautoreconf
38 }