media-sound/lollypop: Version bump 1.2.22
[gentoo.git] / media-sound / lollypop / lollypop-1.2.22.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python3_6 )
7 PYTHON_REQ_USE="sqlite"
8 inherit python-r1 gnome2-utils meson xdg-utils
9
10 DESCRIPTION="Modern music player for GNOME"
11 HOMEPAGE="https://wiki.gnome.org/Apps/Lollypop"
12 SRC_URI="https://adishatz.org/${PN}/${P}.tar.xz"
13 KEYWORDS="~amd64"
14
15 LICENSE="GPL-3"
16 SLOT="0"
17 REQUIRED_USE=${PYTHON_REQUIRED_USE}
18
19 DEPEND="${PYTHON_DEPS}
20         dev-libs/appstream-glib[introspection]
21         dev-libs/glib:2
22         dev-libs/gobject-introspection[cairo]
23         dev-python/pycairo[${PYTHON_USEDEP}]
24         dev-python/pygobject:3[${PYTHON_USEDEP}]
25         gnome-base/gnome-common
26         x11-libs/gtk+:3
27 "
28 BDEPEND="${DEPEND}
29         dev-python/pkgconfig[${PYTHON_USEDEP}]
30         dev-util/desktop-file-utils
31         dev-util/itstool
32         dev-util/intltool
33 "
34 RDEPEND="${DEPEND}
35         app-crypt/libsecret[introspection]
36         dev-libs/totem-pl-parser
37         dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
38         dev-python/dbus-python
39         dev-python/pillow[${PYTHON_USEDEP}]
40         >=dev-python/pylast-1.0.0[${PYTHON_USEDEP}]
41         media-libs/gst-plugins-base:1.0[introspection]
42 "
43
44 RESTRICT="test"
45
46 pkg_preinst() {
47         gnome2_schemas_savelist
48 }
49
50 src_install() {
51         meson_src_install
52         python_foreach_impl python_optimize
53 }
54
55 pkg_postinst() {
56         gnome2_gconf_install
57         gnome2_schemas_update
58         xdg_desktop_database_update
59 }
60
61 pkg_postrm() {
62         gnome2_gconf_uninstall
63         gnome2_schemas_update
64         xdg_desktop_database_update
65 }