media-sound/lollypop: python 3.{7,8} support
[gentoo.git] / media-sound / lollypop / lollypop-1.1.4.16.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python3_7 )
7 PYTHON_REQ_USE="sqlite"
8 HASH="6b4e4e7a2c17f0770c1e2b3354ae5a3a"
9 inherit python-r1 gnome2-utils meson xdg-utils
10
11 DESCRIPTION="Modern music player for GNOME"
12 HOMEPAGE="https://wiki.gnome.org/Apps/Lollypop"
13 SRC_URI="https://gitlab.gnome.org/World/${PN}/uploads/${HASH}/${P}.tar.xz"
14 KEYWORDS="amd64"
15
16 LICENSE="GPL-3"
17 SLOT="0"
18 REQUIRED_USE=${PYTHON_REQUIRED_USE}
19
20 DEPEND="${PYTHON_DEPS}
21         dev-libs/appstream-glib[introspection]
22         dev-libs/glib:2
23         dev-libs/gobject-introspection[cairo(+)]
24         dev-python/pycairo[${PYTHON_USEDEP}]
25         dev-python/pygobject:3[${PYTHON_USEDEP}]
26         gnome-base/gnome-common
27         x11-libs/gtk+:3
28 "
29 BDEPEND="${DEPEND}
30         dev-python/pkgconfig[${PYTHON_USEDEP}]
31         dev-util/desktop-file-utils
32         dev-util/itstool
33         dev-util/intltool
34 "
35 RDEPEND="${DEPEND}
36         app-crypt/libsecret[introspection]
37         dev-libs/totem-pl-parser
38         dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
39         dev-python/dbus-python
40         dev-python/pillow[${PYTHON_USEDEP}]
41         >=dev-python/pylast-1.0.0[${PYTHON_USEDEP}]
42         media-libs/gst-plugins-base:1.0[introspection]
43 "
44
45 RESTRICT="test"
46
47 pkg_preinst() {
48         gnome2_schemas_savelist
49 }
50
51 pkg_postinst() {
52         gnome2_gconf_install
53         gnome2_schemas_update
54         xdg_desktop_database_update
55 }
56
57 pkg_postrm() {
58         gnome2_gconf_uninstall
59         gnome2_schemas_update
60         xdg_desktop_database_update
61 }