media-sound/alsa-utils: amd64 stable wrt bug #720810
[gentoo.git] / media-sound / lilycomp / lilycomp-1.0.2-r2.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python2_7 )
7 PYTHON_REQ_USE="tk"
8
9 inherit python-single-r1
10
11 MY_P="${P/-/.}"
12
13 DESCRIPTION="graphical note entry program for use with LilyPond"
14 HOMEPAGE="http://lilycomp.sourceforge.net/"
15 SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
16
17 LICENSE="GPL-2"
18 SLOT="0"
19 KEYWORDS="~amd64 ~ppc ~sparc ~x86"
20 IUSE=""
21 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
22
23 DEPEND="${PYTHON_DEPS}"
24 RDEPEND="${DEPEND}"
25
26 S="${WORKDIR}/${MY_P}"
27 HTML_DOCS=( "${S}/lilycomp.html" )
28
29 src_prepare() {
30         default
31         python_fix_shebang lilycomp.py
32 }
33
34 src_install() {
35         default
36         newbin lilycomp.py lilycomp
37 }