*/*: Depend on media-libs/mesa[X(+)]
[gentoo.git] / media-sound / imp3sh / imp3sh-0.2.4.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=0
5
6 inherit toolchain-funcs
7
8 DESCRIPTION="flexible playlist manipulation shell and song player/streamer"
9 HOMEPAGE="https://www.gentoo.org/"
10 SRC_URI="mirror://gentoo/${P}.tar.gz"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="-* x86"
15 IUSE=""
16
17 RDEPEND="sys-libs/ncurses
18         media-libs/libvorbis
19         media-libs/libogg
20         media-libs/libao"
21 DEPEND="${RDEPEND}"
22
23 src_compile() {
24         econf
25         emake CCLD=$(tc-getCXX) || die
26 }
27
28 src_install() {
29         emake DESTDIR="${D}" install || die
30         dodoc README* CHANGES web/README.imp3web web/imp3web.php EXAMPLE.imp3sh EXTERNAL.players
31         # Some docs are liner notes in the actual .c files. UHG.
32         dodoc piped-io/imp3sh*.c
33 }