media-sound/qtagger: EAPI-7 bump, switch to cmake, missing DEPEND
[gentoo.git] / media-sound / gom / gom-0.29.103-r1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit autotools toolchain-funcs
7
8 DESCRIPTION="Console Mixer Program for OSS"
9 HOMEPAGE="http://www.fh-worms.de/~inf222"
10 SRC_URI="http://www.Fh-Worms.DE./~inf222/code/c/gom/released/${P}.tar.gz"
11
12 SLOT="0"
13 LICENSE="GPL-2"
14 KEYWORDS="amd64 ~ppc sparc x86"
15 IUSE="examples"
16
17 DEPEND=">=sys-libs/ncurses-5.2:0="
18 BDEPEND="virtual/pkgconfig"
19
20 PATCHES=(
21         "${FILESDIR}/${P}-tinfo.patch"
22 )
23
24 src_prepare() {
25         default
26         eautoreconf
27 }
28
29 src_compile() {
30         emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
31 }
32
33 src_install() {
34         emake DESTDIR="${D}" install
35         dodoc AUTHORS NEWS ChangeLog README
36
37         if use examples; then
38                 docinto examples
39                 dodoc README
40                 docinto examples/default
41                 dodoc examples/default/*
42                 docinto examples/two-mixers
43                 dodoc examples/two-mixers/*
44         fi
45 }