media-sound/murmur: Revbump replacing user eclass
[gentoo.git] / media-sound / gimmix / gimmix-0.5.7.2.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=4
5 inherit autotools eutils
6
7 DESCRIPTION="a graphical music player daemon (MPD) client using GTK+2"
8 HOMEPAGE="https://launchpad.net/gimmix"
9 SRC_URI="mirror://gentoo/${P}.tar.bz2"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="amd64 ~ppc x86"
14 IUSE="cover lyrics taglib"
15
16 RDEPEND=">=media-libs/libmpd-0.17
17         gnome-base/libglade
18         x11-libs/gtk+:2
19         cover? ( net-libs/libnxml net-misc/curl )
20         lyrics? ( net-libs/libnxml net-misc/curl )
21         taglib? ( >=media-libs/taglib-1.5 )"
22 DEPEND="${RDEPEND}
23         virtual/pkgconfig
24         dev-util/intltool"
25
26 DOCS=( AUTHORS ChangeLog README TODO )
27
28 src_prepare() {
29         epatch "${FILESDIR}"/${PN}-0.5.7.1-curl-headers.patch
30         sed -i -e "/^Icon/s/\.png$//" \
31                 -e "/^Categories/s/Application;//" data/gimmix.desktop
32
33         # broken build system in tarball
34         eautoreconf
35 }
36
37 src_configure() {
38         econf \
39                 $(use_enable cover) \
40                 $(use_enable lyrics) \
41                 $(use_enable taglib tageditor)
42 }