media-sound/qjackctl: removed obsolete 0.6.1
[gentoo.git] / media-sound / gimmix / gimmix-0.5.7.2-r1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit autotools
7
8 DESCRIPTION="a graphical music player daemon (MPD) client using GTK+2"
9 HOMEPAGE="https://launchpad.net/gimmix"
10 SRC_URI="mirror://gentoo/${P}.tar.bz2"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="amd64 ~ppc x86"
15 IUSE="cover lyrics taglib"
16
17 RDEPEND="
18         media-libs/libmpd:=
19         gnome-base/libglade:=
20         x11-libs/gtk+:2
21         cover? (
22                 net-libs/libnxml:=
23                 net-misc/curl:=
24         )
25         lyrics? (
26                 net-libs/libnxml:=
27                 net-misc/curl:=
28         )
29         taglib? ( media-libs/taglib:= )"
30 DEPEND="${RDEPEND}"
31 BDEPEND="
32         virtual/pkgconfig
33         dev-util/intltool"
34
35 PATCHES=(
36         "${FILESDIR}"/${PN}-0.5.7.1-curl-headers.patch
37         "${FILESDIR}"/${P}-format-security.patch
38         "${FILESDIR}"/${PN}-0.5.7.2-QA-desktop-file.patch
39 )
40
41 src_prepare() {
42         default
43         eautoreconf
44 }
45
46 src_configure() {
47         econf \
48                 $(use_enable cover) \
49                 $(use_enable lyrics) \
50                 $(use_enable taglib tageditor)
51 }